PROBLEM
- Every time I send letters, I get an error that says “Unrecognized database format.”
- When trying to send a message, we get the error “An error occurred attempting to send a message.” within the Error Description, it says “Unrecognized database format.”
CAUSE
Unfortunately, we do not have a specific cause as of yet. We know that this issue is only limited to Windows 10 machines, and only affects a small percentage of clients.
SOLUTION
As always, we want to go through some troubleshooting to see if the issue can be resolved. However, if these steps do not resolve the issue, then we have some workarounds that we can provide until we get more information.
Be sure to create a backup of your database between each set of instructions. This way, if the problem persists, you can revert to a backup so as not to lose any data. You can follow the instructions for making a backup here .
Verify that your Letters folder only contains Gorilla letters with the “.one” and “.two” file extensions.
- In Gorilla, click on Tools>Options>Directories and make a note of the Letters Directory.
- Right click on your Start icon and then click on File Explorer.
- Browse to the location that you noted in step “a.”
- Click on the View tab and check the box that says “File name extensions” if it is unchecked. This will ensure you can see the file extensions of all files within that folder.
- Locate any files that are not using the “.one” or “.two” file extension, and remove those items from the folder.
- Restart Gorilla and try sending letters again.
Ensure your computer is not set up to autodisconnect the network drives.
- Right click the Start icon and select Windows Command Prompt (Admin) or Windows PowerShell (Admin).
- In the new window, type in “net config server /autodisconnect:-1” and then press enter.
- You will get a message “The command completed successfully.”
If the above options do not work, you can try copying your database and data folder to a different machine, and share from the new location. Because this can be a little more extensive to get done, if you need help with this step, please call Software Support at 801-553-9888.
WORKAROUND
If none of the steps above work for you, then we recommend trying one of the following workarounds until we get more information on what is causing this issue.
- Have everyone in the office exit out of Gorilla.
- The person who needs to send letters can log back in once it is verified that everyone else has exited.
- With just one person in Gorilla, go ahead and send letters.
An alternate workaround is to get a Windows 7 machine set up with Gorilla on it and send letters from it. Because this issue only occurs when sending letters from Windows 10 machines, you can safely send letters from a Windows 7 machine without having to kick anyone out first.