An Unexpected Syntax Error (Missing Operator)
PROBLEM
- Getting the following error message in scheduler:
CAUSE
There are a few reasons you may be getting this error:
- You have one or more Staffgroups without any system users in them.
- The System Users within one or more Staffgroups are inactive.
- You are filtering items in the Scheduler by a System User that is inactive.
- You are filtering items in the Scheduler by a System User that is active, but not assigned to any Staffgroups.
- You have quotation marks within the name of a campaign.
SOLUTION
- Click on Tools>Team Management.
- Look for any Staffgroups that do not have any System Users listed.
- If you find one, highlight that Staffgroup and then choose “Delete” from the right side of the screen.
- Note: You may get prompted with a message about actions and objectives being assigned to the staff group. Click “OK” on that message, and then you will be given the opportunity to choose a Staffgroup that you can reassign those items to.
- Click to highlight a System User within a Staffgroup.
- Check the right side of the screen and make sure the Active box is checked next to the System User.
- If that box is unchecked, check it.
- If the System User is no longer needed, click to highlight the Staffgroup and then uncheck the System User name from the right side of the screen.
- If this causes the Staffgroup to no longer have any System Users, delete the Staffgroup.
- If you are filtering items by a specific user, make sure you see that user name within one of the Staffgroups. If that System User does not show up, click on the Staffgroup that they should be in, and then check their name on the right side of the screen to add them.
If none of these steps work, check the filters within the Scheduler and make sure you are set to view All.
- From the Scheduler, click on the Filter icon from the top left of the screen.
- On each tab available, click on “Select All.”
- Once everything is selected, click “Apply.”
Check your campaigns to make sure one does not exist with quotation marks, if you see one in there, you will need to delete it.
- Go to Campaigns > Campaign Manager.
- Go to File > Delete and then choose the campaign in question.
Now that the campaign is deleted, you can recreate it following the steps in the knowledgebase article: Activating a campaign.
Be sure to leave out the quotation marks when you create the campaign.
If this does not resolve the issue, please call Software Support at 801-553-9888 for further assistance.
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